Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 30, 2025 - 21:00 CEST
Scheduled
Some of SocialHubs satellite services are being downed for maintenance during short, intermittent timeframes (5-30 minutes each) in the allocated timeframe.
Affected services: * Single-Sign-On Login to the Hub * SocialHub Addons (ideaboard, employee advocacy) * Custom Integrations (flip, google my business, mastodon, trustpilot, applestore, google play store) * Login to the Hub
Posted Jul 07, 2025 - 09:50 CEST
This scheduled maintenance affected: Frontend (ENV1).